Actualización de TouchOSC con soporte para iPhone 5

COMPARTIR 0 TWITTEAR

Por fin los que usamos TouchOSC en un iPhone 5 como controlador tenemos la esperada actualización. No, el desarrollador no estaba muerto. Por una parte causas ajenas a él y por la otra problemas con el proceso de sumisión de la App Store. TouchOSC dejará de ser compatible con iDevices antiguos dando paso a los nuevos, a partir de iOS 4.3. Una puesta al día necesaria.

Actualización de TouchOSC para iPhone 5

¡Uau! parece increíble que a estas alturas aún queden aplicaciones que no sean compatibles con la pantalla Retina del iPhone 5, pero así es. TouchOSC era una de ellas de la que hemos hablado en varias ocasiones en Applesencia durante nuestra serie de entradas sobre como ser DJ en un Mac. Parecía que el desarrollador había desaparecido pero hoy ha dado señales de vida.

Según explica él mismo en su blog, después de pedir disculpas, todo empezó con el lanzamiento del SDK de iOS 6 junto con el iPhone 5. Este nuevo kit de desarrollo dejaba de dar soporte a aplicaciones por debajo de iOS 4.3. La voluntad del desarrollador siempre ha sido que TouchOSC fuera compatible con el mayor número posible de dispositivos y así dar una segunda vida a aquellos más antiguos y que no servían para otra cosa.

Hexler desarrolló un código para hacer compatible la aplicación tanto con los dispositivos antiguos por debajo de iOS 4.3 y los actuales, pero evidentemente la App Store rechazó tal código, además de ser necesario adaptarla al iPhone 5 debido al últimatum que mandó Apple hace dos meses. Así que si queréis seguir utilizando TouchOSC en vuestros antiguos iDevices lo mejor es que guardéis la aplicación .ipa a buen recaudo ya que cuando iTunes la actualice ya no podréis volver a descargarla.

Pero vamos con las novedades, ya que si tienes un iPhone 5 ¡estás de enhorabuena! Ahora es totalmente compatible con la pantalla Retina de 4 pulgadas y por supuesto el editor de plantillas es compatible con esta medida —debes bajarte la última versión del editor—. TouchOSC 1.9.0 también incluye nuevos tipos de mensajes MIDI, un nuevo control de los paneles XY, resuelve un problema con la conexión virtual CoreMIDI y retira la compatibilidad con MIDIMobilizer Mk I, ya que ha pasado a ser obsoleto y ni el fabricante da soporte. Es mejor actualizarse al Mk II que soporta CoreMIDI.

App Store | TouchOSC (2,69 euros)

Archivado en Actualizaciones, App Store, iOS, iPhone 5, MIDI, TouchOSC
COMPARTIR 0 TWITTEAR

Comentarios (18)

Usa tu cuenta de Facebook para dejar tu opinión.

Otras webs de Difoosion